[Solved] Minus (subtraction) sign not showing up with laptop

 I've been on Classcraft for a few years and consistently run into the problem that Classcraft does not respond to my using the minus key when I want to remove points for XP, HP, AP or GP. This is the case with the keyboard and the USB numeric keypad. Sometimes if I keep the key pressed for a while it occasionally shows up in the box where I'm trying to insert it. Has anyone else having that problem found a work around?

Hello Andre, 

Thanks for sharing this! In some parts of the game, it may be impossible to enter a negative amount of points. Could I please know which point type and in which part of the game you are attempting to give negative points?

Looking forward to providing some extra clarity! :)

I can't type a "-" after clicking on the  -/+ button, be it under the individual player, team setting or class setting. I end up having to turn on the cell phone, go on the app, and do it there instead which is quite inconvenient. Especially since I don't always bring it to school with me.

Hi Andre,

What device and browser are you using? 

Our supported browsers are Chrome, Safari and Edge. If you aren't using one of those, could you try again on one of the browsers I mentioned and let me know if it works?

Also, if it does not, the best way to troubleshoot this would be one-on-one, via a support ticket! 

Hope this helps!

Thanks. I'm on Windows 7 and use Firefox. I already have two browsers installed and have avoided installing Chrome so I'll simply continue using the cellphone on those occasions when I need to use a minus sign.

Thanks for the info, Andre. 

If you do have one of the supported browsers, maybe just try it out to see if it works? There's a good chance that this might be a Firefox compatibility situation. 

Thank you for the reply, Andrew.

I have Firefox and Explorer (v.11) on my system and Classcraft does not work at all with Explorer. I get a blank page whereas the only issue I have with Firefox and not being able to use the minus sign in an area where I want to enter a negative value. Otherwise the minus sign works in an area that accepts text.

Hello Andre, 

Thanks for the additional information. To be clear, Firefox and Internet Explorer are not browsers that can support Classcraft. You can expect various, changing and unexpected stability issues when using a browser that is not supported. 

If possible, please use either Chrome, Edge or Safari. 

I have the same problem. If I have a 10-key pad I can add a minus sign before the value, but it dosesn't work if I use the hyphen from number keys on my QWERTY keyboard.

Edit: I just tried it using Chrome (Mac) and it worked. Firefox (Mac) isn't working.

Cette publication n’accepte pas de commentaire.