[Solved] Site graphics doesn't load in the classroom

Really wanted to try today's event and the boss battle in class - but the site's graphics doesn't load in class.

Any idea what can be done?

It loads pretty quickly when I'm at home - but doesn't work in class.

Hi Or-Tal,

Is this a recurring issue, or was that only yesterday? Which browser and device are you using in class? Are they different from what you use at home?

This is recurring - for the past 3 lessons. I tried using Opera, IE and Firefox (Chrome is loaded with malware lately so I had to remove it from my computer).
I am using my own laptop in class and at home.

Hi Or-Tal,

Classcraft only supports Safari and Chrome. The game may not work correctly if you use other browsers.

Reluctantly I will give Chrome another chance and download it again. I've had a lot of trouble with malware and spyware in Chrome, that's why I left it for the other browsers. I had no problem using Classcraft on all 3 browsers I have - only not in the classroom. It worked in the teachers' lounge at school, but not in the classroom, not on wireless nor on wired. Strange.

I have had the same problem with Chrome in my school laptop for a week now.  The graphics load just fine in Chrome on my personal computers and on the desktops in my classroom, but not on the laptop I use with the LCD projector.  Is there some program or add-on I should update?  There are no Chrome updates available (I searched).  I've been showing Classcraft in Firefox during class just so the kids can see the graphics, but there are things (like changing the wording in a random event) that are not functional in Firefox.

Hi, Pam!

When images load correctly in Firefox, that's on the laptop you use with the LCD projector?

Also, could you share screenshots of what the graphics look like in Chrome when you use the laptop?

Thank you!

Just a followup note -- after a lot of searching, I finally came up with a BIOS update for my classroom Lenovo ThinkPad that fixed the graphics problem when using Chrome.  We are happily back to normal!

Hi Pam,

I'm very happy to hear that!

I've been using it Chrome for a few years now. But since yesterday all of a sudden, everything looks like it was loading on a dial up modem. I don't see menus, big icons, missing images, looks like old school html websites...

I've attached a screenshot below.

Any help would be great. I've updated to the latest Chrome and tried on different PCs. At the moment I'm running it on Firefox as it still works on that.

Thank you!

Hi, Jung!

I'm sorry about that: We had a technical problem, but it has been fixed. Everything should now work properly with Google.

Let us know if you're still having issues! Thanks. 🙂


I am having the same issues as Jung. My screen looks exactly the same as his screenshots and it has been days since you posted that there was a technical problem that was fixed.  Is there anything I need to do on my end?

I think it might've had something to do with some of the addons/extensions I was using on Chrome, because after Anne-Marie's response it worked on a "clean" version of Chrome (on the computers at school), but I still had issues on my browser at home.

In saying that though, today it worked on my home PC's browser too.

Also, in the past, when this happened, I usually put it down to server maintenance or overload as it would only last a day or two.

Hi Jennifer,

Can you please clear your Chrome cache? Hopefully this will solve the issue.

Please let me know if it works!

I had the same problem with safari. When I cleared the history everything went back to normal.

Thanks, Lisa! That's good to know.

Cette publication n’accepte pas de commentaire.