[Solved] iOS app issues

Two problems with the ios app.

First one, this happened with my iPhone. When the app is newly installed it does not stay on the login screen (where you choose to login with Google or your username/password). It goes straight into selecting your character. But, after you've selected gender/look/class it goes to a blank screen that is titled "Choose Your Class". It seems useless for students with existing accounts to download the app.

Second issue. I had the app previously installed on my iPad and am able to log in. But, after logging and clicking on "Equipment" the app crashes. I tried this multiple times from different screens. It always crashed.

Maybe this has to do with the iOS 10 update?????? Or maybe not. Either way these issues should be addressed.

Thanks for your patience on this. I checked with our development team:

We're working on fixing the first issue. In the meantime, the students with this problem needs to access Classcraft on a computer in order to enter a student code and create their character. Once this is done, they can use the iOS/Android app.

The second issue has been fixed.

Commentaire officiel


I have been having some problems with ios app as well. Whenever I start the app, the screen below is a constant, the whirling thing makes me nauseous after some point. Then I close the app. Try again. And sometimes, for a change, I turn off the phone and repeat the process to no avail. So I need to know, the problem is about the compatibility of updated app/ios or something with the phone itself (iphone 4s)?

Btw, interestingly, whenever there is an update on appstore, it's automatically downloaded even though it doesn't make any difference. I am really confused. Should I just give up? Help please!

The first issue has to do with students that already have accounts that they created on a computer through the browser side of the game. The first issue is that they cannot access the game on their phone after their character has been created because it either just gets stuck on the login screen with the whirling circle or goes straight into creating a character. It never gives a chance for the user to click on a login option (with Google or with Username).

Hi Edward, hi Gamze,

I'm sorry about the delay in response. Are you still experiencing issues?

Thank you!

Yes, every time I try to open the app on my iphone it still goes directly to creating a character. It never allows me a chance to log in to my account.

Hi Edward,

I've created a ticket to investigate further.

Thanks for your patience!

Similar app problem, but different! My problem is that when I log into the app, it says I have to select a class. When I select a class, it tells me that I have no students in that class. When I look on the computer, all 22 of my students show up, but the app still says there aren't any. How can I resolve this? I've tried logging out and logging back in. The app worked for a short while, then went to this issue. Thank you.

Hi Jennifer,

Since I need some personal information, I've created a ticket for you.

Is there a way to turn in assignments through the app?  Also, how do students download pdfs that are posted? They can only view them and there does not seem to be a way to export them to their Google drives or Notablility.

I am having the same trouble like the others. My students show up on the computer but on my ipad and iphone. Please respond soon. Nupur Sethi

Hi Nupur,

I will create a ticket for you in order to notify the dev team. You will receive an email from Classcraft.

Thank you!

I am having the same issues.  When I enter the app I log in fine, and my first class shows up ok.  But then if I try to go to another class, or leave the app and come back, it says the class is empty.

Thanks for the info, Douglas! The dev team is currently investigating the issue. I'll create a ticket for you as well.

Another app issue.....same as Gamze above! I get the spinning wheel of doom when I open the app on my ipad. I closed the app and retried, same issue. I uninstalled and reinstalled same issue. 

Hi Kristy,

Could you let me know what version of the app you're running?


I have also an app issue recently....I have same problem when I log into the app, it says I have no active classes. But when I go to the computer browser I have all my classes and students. The version of my app is 3.0.7.  How can I resolve this? I've tried logging out and logging back in and reinstalled the app for the third times. Thank you.

Same Issue as Andy.

Same as Andy and John. Just started doing this Friday Jan 19. Frustrating to tell my students I'm add or taking points and not be able to. 

Hi everyone,

We are aware that some app users might be experiencing some troubles with their classes today. Please rest assured, our Dev Team have already begun working on a fix!

I will be creating tickets for you, Andy, John and Stephanie, so that we can update you as soon as we have more info. 


I log in to my app on my iphone and there are random names of students that I don't recognize.  I've logged in many different times to no avail. 

Hi Cassie, 

Thanks for sharing this. I'm sorry to hear that you're stuck, but I can certainly help you!

You may actually be looking at the demo class! If you count only 8 students with strange names, then this is the case! Simply open the menu on the app (☰) icon in the bottom right corner of the app then, you should find a list with the names of your classes in a drop-down menu, at the top of the screen.

Hope this helps! Let me know if you still need some assistance. We will be more than happy to help get you all set!

I really appreciate the topic which you have discussed over here. Recently I have been tried to download iOs App but I got iPhone Error 0xe8000015. it was quite frustrating, then I took assistance from the support team.

I am having issues with the iPad app. My classroom is using 4th generation iPads with IOS 10.3.3.  That is as far as we can update the machines. I have some computers in the room but not 1:1.  I have 1:1 iPads.

Several times, when the students attempt to navigate to quests, the screen will go white.  I will have to completely close the app and restart it.  That will usually work, but sometimes not.  I also run into the problem of the app getting stuck trying to reload after sitting idle for a time.

Are these known issues? Are their any fixes?

Any help would be greatly appreciated.

Thank you


Hi Scotti, 

Would you be able to send us a detailed email to support@classcraft.com including the Classcraft app version, name of the student and quest this is happening to, so our developers may investigate this further?

Thank you.

Cette publication n’accepte pas de commentaire.