[Solved] Not able to upgrade to Premium

I've just come up on the last days of my Premium trial and when I tried to hit the submit button on the payment information page it does nothing. I'm not going to hit the button any more times as I tried 3 times and do not need to get billed 3 times if it actually was working. It seems like the button is perhaps coded incorrectly.

Well, nevermind, it miraculously fixed itself. Might have had something to do with the trial month... who knows...

Hi Ryan,

I'm very sorry you had trouble upgrading, but I'm relieved to hear everything worked out. 😅

I have tried several times with a Suntrust Mastercard and it keeps saying the card number is incorrect. My husband even tried his card and it says the same thing 

Hi Shannon,

I am sorry to hear that your payment method is not working. Here are a few other options you can try :

1) Go to shop.classcraft.com to purchase a One Year Classcraft Premium license. Sometimes cards are not accepted on our platform but will go through on the online store.

2) Make sure the name you enter is exactly the same as the one on the credit card, if this credit card is a your school's credit card, it is possible that it is to someone else's name and not the school.

3) If it still does not work, please contact your bank to request allowing the transfer to go through as sometimes banks will block the transaction from the U.S. since we are situated in Canada.

Cette publication n’accepte pas de commentaire.