Student Codes are not working



I have two student codes that are not working for their first time log-in.  How do I fix that?


Hi Shauna, 

I created a ticket with your post and I would need some info to fix the issue. :)

The other thing I would do is delete their character after writing down how many xp they had and give them another one.

I also have a few students that are not able to login using their Google credentials. Either they get the dreaded infinite login loop or it tells them the class code is invalid even though I have reset it several times.

Hey, Kevin,

So sorry to hear you're having trouble getting your students connected. Here's what I suggest you try:

  • For students to log-in using Google for the first time, you should first "import" their accounts over into your Classcraft class via the Google Classroom import button. You can find that by clicking on "Configure Class" (the gear icon at the bottom of the left sidebar) > Students > Import students > Import from Google Classroom.  
  • If you do not have Google Classroom set up. Your students first need to create their Classcraft accounts using the Google Button from https://game.classcraft.com/signup/student 
  • By doing that, they will first need their unique student code (found adjacent to their names in your student list from the Configure Class page).
  • The Class Code is actually to connect students who already have existing Classcraft accounts - with an archived character from a previous year - to your class. 

Hope this helps! Let me know how it goes. :-)

Please sign in to leave a comment.