Classroom Setup Prompt



My classcraft classes have been configured and set up for awhile now, but after the last update it keeps prompting me to finish my class setup when I try to login to my classroom. My setup is completely finished and I end up having to type in a false student name just so I can get to my classroom home page.

 

Please Help!

Chris


Hey, Mr. Crossley! 

We would love to help you out with this, but will first need some more information. I've gone ahead and created a support ticket for you. 

We shall be in touch shortly!

 

I'm having the same issue.

Hi there,

Thanks for sharing. Is your account setup fully completed as well? We have had a few reports of teachers experiencing trouble with this in the past few days, so our Dev Team is currently investigating.

This is something you're seeing only once in a while, correct?

This has been happening to me for a while now.  Not sure when it started.  It always seems to fix itself if I just refresh the page.

Thanks for the info, Douglas! I'm sure it'll come in handy for the Dev Team. 

So that means it hasn't stopped you from accessing your classes, right?

It has not stopped me, but it happens most days, though not consistently on one class.

My classes are completely set up and I have used them. Although I haven't used them in a few weeks because I've been out sick and now I can't get into any of my 3 classes. All 3 classes are requiring me to finish the set up.

Thank you for the follow-up, everyone. 

I'm sharing this with the team and am truly sorry for any inconvenience this might have caused. Please know that we're looking into this intently and working hard to get it fixed as soon as possible.

We understand what it means to try new things to help the kids learn and grow. Sometimes, it's just not that easy, and that's precisely why we're doing our best to make things better. 

Thank you for your feedback!

I am having this same problem, too. I am also unable to delete classes that were created but wasn't able to add students. 

Hi Cary, 

We have performed some updates to the system since you posted this, could you verify if you are still experiencing these concerns?

If so, let's move this to a private conversation so you may share with us more detailed information, by emailing us at support@classcraft.com 

Thank you.

Please sign in to leave a comment.