[Solved] Equipment Changes Not Updating

One of my students used gold pieces to purchase new equipment, and saved their changes to their avatar. However, these cosmetic changes are not appearing on the Game Dashboard or their individual Avatar Dashboard. I've even gone into their account, equipped a different set of gear, and re-equipped the new gear they purchased. That did not help. Any support would be appreciated!

This happened to one of my students, and I told them to just check again the next day.  It was fixed when they came in the next day.

Possible fix (it worked for us today anyway). Have students change back to another set of equipment and then re-equip the desired gear. My students all reset and then re-equipped this afternoon and it worked perfectly! Good luck, guys~!

This worked for me: Today, I went in on a different browser (Safari---I usually use Chrome), equipped a different set of gear on the student, and then switched back to their newly purchased items. This seemed to take!

Hope that works for others. Thanks all for your input.

It's not working for my students either and it's been almost 24 hours ><

Same issue here... I've had a number of students from different class that have bought gear, saved their character with the new gear equipped, and then it doesn't show up on their current avatar. 

Hi everyone,

We deployed a fix for this issue today!

As Bri mentioned, students should go into their accounts, re-equip their gear, and save the changes.

Please let us know if you're still experiencing any issues!

Post is closed for comments.