[Solved] Beginning Quests

I attempted to use a quest today, however students were unable to get past the introduction. I was unable to push them forward on my end and they could not move forward on their own. Has anybody encountered this and have advice for me? Thank you!

I do have the simple problem, and my linkds seems corrects...


I meant: I do have the SAME problem

I have the same issue with students who have started a quest but cannot move to the next section


Have you gone to the quest on your own screen, hit the specific task they are stuck on and then press the check mark next to their name? Once you have pressed the green checkmark next to a students name they are able to advance to the next task.


If you want to avoid having to check each student off, make each task a "Quest End" you can still place more things after that. It is a false named thing - Quest end just means a task that has no need for you to check them off as they go.

I too am having trouble with setting up a quest.  I started one and wanted to add more steps along the quest but the program won't let me get back in to add more to the original quest.  Is there a way to edit the quest?  For instance, maybe I need to not put the Quest End date in for each task but only for the whole assignment(s)?  I'm frustrated that it is not more user friendly because it seems like such an exciting way to get my students motivated to learn.  Any help would be greatly appreciated.  I have a trial membership but won't be purchasing a membership if I can't use the program as it seems intended.

Hi Joyce,

I'm sorry that you're having trouble setting up your quest. At any time, when you access your quest, you can add objectives, create new paths, or edit your tasks.

I hope the following article, Adding lesson objectives to you map, will help you. You can also check out our series of articles on Quests here.

Please let me know if you have further questions!

I may be completely off base here, but I thought I'd check anyway, because I ran into the same problem with my students. 

Do they know they need to click the X in the top right hand corner to close the introduction screen?


I had to explain that to my kids and didn't have any problems after that.

Hope it helps!

I had them click the x on the introduction, however no new tasks appeared. The arrows were in the correct direction for the classes in which I attempted to use the quest. They were off for some of the ones I didn't bother to use so I'm sure that would be in issue for those classes. The only way students were able to gain access to my first task was for me to give them a check on that task (even though they couldn't see it to complete it). Once they got credit for the first task the rest of the map would open up as it is supposed to.


Thank you to all who have suggested solutions!

One suggestion I have for Classcraft on this issue is that it would be helpful to be able to switch into student mode. It is almost necessary when working with elementary school aged children because modeling is huge. I'd also like to test quests before I make them visible. I guess I could create a test student account, but I feel that Classcraft could easily do this for us. 

I'd like to add an assignment to a quest but I want to do it through Google Classroom so that the Google Doc is automatically named and assigned to every student in my class. Is there a way to do that in Quests?

If I just attach a Google Doc to the Quest task, will every student be using the same Google Doc or will it create a separate one for each student?

Hi Adam,

At the moment, if you add a Google doc to your task, students will need to make a copy to work on it individually.

That being said, Google integration in Quests is our next project this fall!


Hi Victor,

Thanks for the suggestion! Good idea.

"That being said, Google integration in Quests is our next project this fall!"


 -----YAASSSSSSS!!!!!!!!!!  *happy dance*
Thank you!


I too, am having problems with my students moving past the Introduction.  They all have a green check and they have tried to click the corner x to close the Introduction screen, but it just takes them back to the map.

I'm noticing that the Introduction button is gray instead of green, which would make me think it isn't active?

I've clicked Enable Self Progress too.

I'm so frustrated!! I worked a long time creating this quest and now they can't use it!  ARGHHH!!!

Hi Shari, 

You seem to be really frustrated right now - and I totally get it. I understand how you feel and I genuinely want to help! This could sometimes be happening because of a linking issue between Quest Objectives. Could you make sure that everything is properly linked?

If that doesn't do it, what Classcraft class and Quest, specifically, are you having trouble with? I could have quick look at it from my end to figure out what's going on.

Really looking forward to getting you up and running soon!

How do I reorder my tasks or delete a path arrow? I have too many paths drawn and I need to delete one, however, the "delete path" button is grayed out. I've been playing around with it, but am tired of spinning my wheels.

Hi Susan, 

The order of the tasks is determined by the paths that are connected from the 'Home' to next task and so on. 

Here are some examples:

This path orders the tasks as follows: 

When I change the path as follows:

It changes the order like so:

I hope this helps if you need more details please feel free to send us an email to support@classcraft.com and we can review this in more detail with you. :)

Post is closed for comments.